RENAME timeout when using Cornerstone with StatsTrack

RENAME timeout when using Cornerstone with StatsTrack

Scenario:

When using Cornerstone MFT Server 2019 in conjunction with the StatsTrack reporting system, you may experience a delay or timeout when attempting to rename a file or directory using either an SFTP/FTP client or the WebUI browser interface. After the timeout occurs, disconnecting and reconnecting will display that the rename was successful.

Cause:

The StatsTrack engine stores full path information in the database in order to provide accurate data for auditing and reporting purposes. If the Statistics Rotation Schedule is set to an extended period of time, such as Annual Rotation, and/or the Cornerstone server is under heavy usage, this table can become very large.

During a Rename operation, file paths in the database need to be updated to accurately reflect the new name. The more data present in the database, the slower this process can become and sometimes can result in the SFTP client or WebUI reporting a timeout. Disconnecting and then reconnecting to the Cornerstone server will display the correct name of the item.

Workaround:

This is a known issue with Cornerstone MFT Server 2019 and earlier editions. To work-around the issue, set the statistics rotation schedule to be Monthly or Weekly and include the Archive Statistics Before Rotation to ensure all data is moved to the archive tables prior to rotation.

SRT is aware of this issue and is working to have it corrected in the next major release of the software due out in 2021.